Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Friendly Flusi (powered by GNC). Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 2. April 2012, 17:27

Merkwürdiges Problem mit Saitek X52 Throttle

Hallo zusammen,

ich habe folgende Hardware/Software Konfiguration:

Saitek X52 Throttle
Saitek Pro Flight Yoke
CH Pedals

Windows 7 Professional (64-Bit)
FSX SP2

Seit einigen Tagen habe ich das Problem, dass bei Betätigung des Schubhebels plötzlich das Fahrwerk eingefahren wird. Ich dachte erst an eine Fehlbelegung im FSX oder FSUIPC, aber da ist nichts. Im FSX habe ich die Joystick-Belegung der Achsen und Knöpfe praktisch gelöscht, alle Achsen und Knöpfe sind mit der FSUIPC zugeordnet. Aber weder am Throttle noch an dem Yoke ist ein Knopf für das Fahrwerk belegt (das fahre ich im VC meistens mit der Maus ein/aus).

Interessanterweise tritt es bei jedem Flug nur 1x auf, meistens beim Taxi-Out, hauptsächlich bei der PMDG NGX.

Bin echt ratlos... woran könnte es liegen? Hardware-Fehler oder Konfigurationsfehler?

VG,
Dirk
---
i7-2600K (derzeit nicht übertaktet), Noctua NH-14 CPU-Kühler, ASUS P8P67 Deluxe Mainboard, 8 GB DDR3-1333 RAM, Nvidia GTX560, Windows 7 Professionell (64bit), FSX SP2

2

Montag, 2. April 2012, 21:36

Hi Dirk,

Im FSX habe ich die Joystick-Belegung der Achsen und Knöpfe praktisch gelöscht,



inwiefern "praktisch"? Wirklich sicher oder wahrscheinlich?

Um sicher zu gehen, könntest Du ja in Deiner standard.xml alle Joystickeinträge löschen.
(Ausführliche Anleitung dazu im LINDA manual)

Oder aber, Dir ist in FSUIPC aus Versehen irgendwo eine Zuweisung reingehüpft.
Dazu einfach mal Deine FSUIPC4.ini auds dem Modules Ordner rausnehmen (also Backuppen) und den FSX starten.
Es wir eine neue INI erstellt ohne jegliche Zuweisungen. Wenn das Problem immer noch besteht, müssen wir mal woanders gucken ...
Günter

endlich Berliner! :lol:
i7 930@4.2Ghz WaKü, GTX 470 AMP, 6GbRAM1600, Win7 64 Prof


3

Montag, 2. April 2012, 22:14

Hi Günter,
danke für Deine Antwort.

Die einzige Zuordnung, die ich im FSX bei den Joysticks habe stehen lassen, ist der Hat-Switch am Pro Flight Yoke. Alle anderen Zuordnungen sind gelöscht (auch in der standard.xml).

Ich habe heute abend noch mal ein paar Tests gemacht: interessanterweise tritt das Problem auf, wenn der Schub-Hebel das erste Mal bewegt wird, danach nicht mehr. Es trat erst dann wieder auf, wenn der Schubhebel lange Zeit nicht bewegt worden ist (im Anflug, als ich den A/THR disconnect gemacht habe). Auf jeden Fall habe ich mich tierisch erschrocken, als im short final bei 1200' plötzlich das Gear eingefahren worden ist... :huch:

Ich werde mal Deinen Rat befolgen und die FSUIPC.INI woanders hin kopieren und dann weitersehen.

VG,
Dirk
---
i7-2600K (derzeit nicht übertaktet), Noctua NH-14 CPU-Kühler, ASUS P8P67 Deluxe Mainboard, 8 GB DDR3-1333 RAM, Nvidia GTX560, Windows 7 Professionell (64bit), FSX SP2

4

Montag, 2. April 2012, 22:17

als im short final bei 1200' plötzlich das Gear eingefahren worden ist.



jep, das wird leicht hektisch :D

mach das mal mit der FSUIPC.ini.
Man kann ja auch Funktionen auf die Achsen legen, vielleicht ist Dir da aus Versehen was reingerutscht ...

Du hast aber nicht aus irgendeine Maussoftware, die ab und an ein "G" raushaut?
Günter

endlich Berliner! :lol:
i7 930@4.2Ghz WaKü, GTX 470 AMP, 6GbRAM1600, Win7 64 Prof


5

Dienstag, 3. April 2012, 00:58

mach das mal mit der FSUIPC.ini.


Gesagt, getan. :thumbsup:

Weiß zwar nicht warum, aber ich habe die [BUTTONS] section in der FSUIPC gelöscht und siehe da.... kein Gear lever mit Eigendynamik mehr.

Bei der Gelegenheit habe ich mir dann auch endlich LINDA runtergeladen und die wichtigsten Funktionen programmiert. Eigentlich hatte ich mir das für das Osterwochenende vorgenommen, aber es bot sich jetzt auch an. Tolles Tool, werde es mal in den nächsten Tagen ausgiebig testen. :thx:

Gute Nacht!

Dirk
---
i7-2600K (derzeit nicht übertaktet), Noctua NH-14 CPU-Kühler, ASUS P8P67 Deluxe Mainboard, 8 GB DDR3-1333 RAM, Nvidia GTX560, Windows 7 Professionell (64bit), FSX SP2

ThunderBit

Check Six! ... do or die ...

Beiträge: 3 740

Wohnort: LSZR & LSZV

  • Nachricht senden

6

Dienstag, 3. April 2012, 09:18

Noch ein kleiner Input von mir, da auch ich alle drei Geräte (X52 und Yoke und Pedals) von Saitek im Einsatz habe ...

Bei mir habe ich die (leidige) Erfahrung gemacht, dass ich nie beide Geräte gleichzeitig anhängen sollte. Der X52 und der Yoke (mit Schubregler) übersteuern (oder beissen!) sich offensichtlich im FSX. Das heisst, dass plötzlich Funktionen und Tastenbelegungen entweder nicht mehr gehen, oder eben eine andere Funktion auslösen. Wenn ich zum Beispiel beim X52 die Taste für Bremsen drücke, wird stattdessen die Sicht geändert - oder wenn ich am Yoke den Mischer schiebe, poppen verschiedene Cockpit-Panels auf ... und so weiter. Mit dem Tip vom Günni habe ich schon oft und mehrmals die Zuordnungen gelöscht, neu belegt ... und dann doch nach ein paar Flügen wieder das gleiche Problem gehabt.

Ich denke, das Problem liegt sowohl am FSX als auch an der Logik, wie Saitek die Steuerimpulse an den FSX übergibt. Nun ja, ich kann damit leben - also entweder den Yoke (für General Aviation oder Boeing/Embraer/BAe) oder den X52 (für Military oder Airbus), aber nie beide gleichzeitg.

:bier:
Tschüss, ThunderBit

Asus P8P67pro3 | i5-2500K @4.42Ghz WaKü | Asus GTX570 CUII 1280 | Win7 pro64 @8GB
FSX (Acc/SP2) | Switzerland ProX | Austria ProX | ORBX Australia | WideFS | FSEarth | UT2+TrafficX
:flieger: Saitek: X52 & ProFlight Yoke & Rudder Pedals | TrackIR 4pro

Scotty

The Flying Gentleman

Beiträge: 373

Wohnort: Nähe EDLA

Beruf: öffentl.Dienst.

  • Nachricht senden

7

Dienstag, 3. April 2012, 14:33

Hallo Peter !

Ich habe auch beides X52 Pro und den Saitek Throttle.Habe auch beides angeschlossen und nutze sie parallel.
Bei mir funzt das ohne Probleme.Ich habe jedoch kein FSUIPC im Einsatz.

Scott


If you like it low and slow join: www.aspirefsx.com

ThunderBit

Check Six! ... do or die ...

Beiträge: 3 740

Wohnort: LSZR & LSZV

  • Nachricht senden

8

Dienstag, 3. April 2012, 15:21

Tja Scotty, so sind die Leiden unterschiedlich :lol:

Ich habe zwar FSUIPC, aber das wird wohl nicht die Quelle des Uebels sein.

Noch eine Geschichte zu Saitek: Tatsächlich habe ich (sehr selten) sogar im Win7 Probleme mit den angeschlossenen Saitek-Produkten. So konnte ich einmal keine Dateien auf dem Desktop doppel-klicken / auswählen. Sobald ich eine Datei angeklickt hatte, wurde sofort die Funktion F2 = "Bearbeiten / Bezeichnung ändern" im Win7 aktiviert. Erst als ich meinen X52 "abgestöpselt" habe, war dieser Zauber vorbei. Ich habe verzweifelt im Steuerprogramm von Saitek nach irgendwelchen F2-Funktionen gesucht, aber nichts gefunden ... und als ich den X52 dann später wieder angeschlossen habe, konnte ich diesen Spuk nicht mehr rekonstruieren ... bis er ein paar Tage wieder von selber begann.

Inzwischen habe ich einen USB-Hub auf dem Tisch, bei dem ich die einzelnen Geräte bei Bedarf zu- und abschalten kann. Ist ganz einfach, und seither problemlos.

8o
Tschüss, ThunderBit

Asus P8P67pro3 | i5-2500K @4.42Ghz WaKü | Asus GTX570 CUII 1280 | Win7 pro64 @8GB
FSX (Acc/SP2) | Switzerland ProX | Austria ProX | ORBX Australia | WideFS | FSEarth | UT2+TrafficX
:flieger: Saitek: X52 & ProFlight Yoke & Rudder Pedals | TrackIR 4pro

9

Freitag, 13. Juli 2012, 19:46

Hier noch eine kleine Erfahrung, die ich jetzt beim Ausetzen meines neuen Rechners gemacht habe:

Um meinen Saitek X52 anzuschliessen, habe ich im Saitek Supportbereich den neuen Treiber sowie die Programmier-Software runter laden wollen.
Aus "Versehen" bin ich beim Download vom X52 pro gelandet. Dieser Treiber funktioniert zwar auch, jedoch können die alten Profile nicht mehr geladen werden.

Anbei das korrekte Vorgehen.

Hier gelangt man zum Download vom X52 pro. Für den "normalen" X52 folglich eine Sackgasse.



Bei Saitek gilt der X52 als Joystick :rolleyes:


Interessanterweise findet man hier auch den X52 pro noch einmal





Wenn man aber danach alles richtig macht, so erhält man hier den richtigen Treiber und Sofware. ;)
cheers
Martin

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Samy« (13. Juli 2012, 19:49)